Reading http://etherealmind.com/cloud-convergence-skills-career-networking/

Great Artical :-)
Jobs will change fast. It also depence where you work at. I started of at a /  Telco on ATM, guess what DSL was added. Oh the Management System is the same as the SDH one…  I moved on because I liked that Internet. I then started with leased line customers… Well guess what… End to End Configuration to the pop and the routing….
Then I changed jobs to a  SMB enterprise,  Doing Router and Switch Managemenent ….. Cause I had linux/unix skills add  server administration.  Because of tight budget, but well we need this service…. There is a software produkt which adds an hardware abstraction layer, so that you can add another operating system to that linux server… lets try that..  Guess what, this works we need more power and wouldn’t it be nice to get a little more uptime and assurance in.. if this server has a failure this and this server will also fail…
oh we need a shared storage for that solution… well gues what…. there are company’s who provide that solution.
Oh we need this server to not reach that server on the same machine… lets do some real interesting routing, switching and security..
My current job title is called „IT System-Manager“ mayby called TroubleShooting Expert, Network Man, (L)Unix Guy, Storage Man, Solution Architect, Security Man, Telefon Man or Cable Guy, ( not to mention all that specific ITIL Rolles)
Yes and that funny thing is… it is stressfull, but also awfully interessting :-)  Having that Skills and knowledge… It is still good to have certification???? I’m currently holding my CCNP, will try my CCIP in a few month, I want my VCP. Next Thing maybe Storage?
Certification is good for your vita, and if you change jobs, but do you really need it??? My next big challenge: being father… Will anybody promote a certificate for that too??

Switching Best Practice – Service Provider Access Ports

In Service Provider Netzen ist die konfiguration von Switchports gegenüber den Workstation leicht anders.

Service Provider gehen hin, und bieten den Kunden einen redundanten Weg ins Internet an. Hier werden dem Kunden 2 Switchports zur verfügung gestellt, welche identisch konfiguriert sind. Der Kund kann dann selber sein Equipment anschliesen.
Bei einen Einfachen Server mit 2 Lan Anschlüssen (Bonding im Failover) stellt dies keine Herrausforderung. Jedoch gehen die Meisten Kunden hin und setzen ihren eigenen Switch oder HUB hinzu.

Also was muss beachtet werden:

1. Spanning-Tree muss durchgehen funktionieren.
2. Es darf kein Trunk zum Kunden Entstehen.
3. Es darf kein Etherchannel entstehen.
4. Das Kunden Equipment muss immer die niedrigste Priorität bekommen und kein Traffic darf über den Kunden Port fließen.
5. AntiSpoofing sollte verhindert werden.

Also Schauen wir uns diese Bedingen an. Als erstes, mal das was wir schon kennen:

int fast 0/1
! schalte CDP aus
no cdp enable
! manuel in den access-modus
switchport mode access
! es wird hier nicht verhandelt
switchport nonegotiate
! Ins richtige vlan setzen
switchport access vlan 123
! Manuelles Setzen Der Ports und das auch vom Kunden verlangen
speed 100
duplex full

Spanning Tree muss weiterlaufen, deswegen darf auch kein portfast enabled werden.
Auf dem Kunden Interface dürfen keine höherwertigen BPDU empfangen werden, und die Kundenseite darf nie „root bridge“ werden
!
spanning-tree guard root
!
! AntiSpoofing
access-class 1 in
access-list 1 permit ip host 10.1.1.1

Also Zusammenfassend:

If I Don’t know whats behind

int fast0/1
switchport mode acces
switchport nonegotiate
switchport access-vlan 123
spanning-tree guard root
no cdp enable
access-list 1 permit ip host 10.1.1.1
speed 100
duplex full

-> If I know there is a workstation
int fast0/1
switchport mode access
switchport nonegotiate
spanning-tree portfast
spanning-tree bpduguard
switchport access-vlan 1234
no cdp enable

Switching Best Practices – Access Ports

Access Ports sind die Ports wo EndStations angeschlossen sind. z.B. Server oder Workstations.

Switchports sollten
1. Kein Spanning-Tree Sprechen
2. Keine BPDU empfangen
3. Nie Trunk Ports werden
4. Kein Dynamic Trunking Protokoll oder Vlan Trunkin Protokoll sprechen
5. Keine Link Aggregation Protokoll, bzw. Port Aggregation Protokoll ( Etherchannels)

Bei FastEthernet Ports sollten bei Servern Duplex und Speed auf beiden Seiten fest eingestellt werden. Bei Workstation sollte die negotiation auf Autoelassen werden.

Für eine Workstation sieht die Configuration dann so aus

int fas0/1
! Manuel auf AccessPort setzen
switchport mode access
! Schalte VTP/DTP aus
switchport nonegotiate
! Schalte Spanning-Tree auf Sofortiges Forwardin
spanning-tree portfast
! ERlaube keine BPDU ankommen
spanning-tree bpduguard
! Disable CDP
no cdp enable
!

Ein Paar Worte zu den Spanning-Tree optionen:
Auf Portfast Interfacen darf nie ein BPDU ankommen.
Hier gibt es 2 Optionen
spanning-tree bpdu filter
& spanning-tree bpdu guard

Beim Spanning-Tree bpdu Filter werden keine BPDU aus dem Switchport geschickt, und auch nicht überprüft, ob welche empfangen werden. d.H. der Switch reagiert wie ein HUB!
BPDU kann also an Ports Richtung Workstation gebracht werden, ist jedoch eine mögliche Schwachstelle für Spanning-Tree-Loops.
z.B. der Enduser könnte einen kleinen HUB anschalten um seinen 2 PC anzuschalten, erwicht jedoch ein Kabel welches zu einen Anderen Switch führt… und schon ist die Schleife Perfekt…

Beim BPDU Guard wird sobald eine BPDU auf dem Interface empfangen wird, das interface in einen Error-Disabled State gefahren. Dieses muss man manuel prüfen und wieder freigeben. Dies Sorgt dafür das ja keine Spanning-Tree Loop entsteht.
BPDU Guard ist also eher etwas konservativer.
Dies kann jedoch auch mit einen: errdisable recovery cause bpduguard auch automatisch nach 300 Sekunden (default) automatisch wiederherstellen.

Hinzu kommt nur noch die richtige zuweisung der Workstation in Ein VLAN.

Zur Access-Controlle gibt es noch weiter Optionen:
1. 802.1x
und
2. port-security.

Bei Portsecurity arbeitet mit statischen MAC-Adressen. Hinter einen Port kann eine oder Mehrer Mac-Adressen vorhanden sein.
ProtSecuity und 802.1x ist jedoch ein Thema, welches hier nicht behandelt wird, Jedoch zur Vollständigkeit genannt wird.

Traumfrau

Ja ich werde Älter….

Das merke ich vor allen Dingen daran, dass alle um mich herum jetzt Heiraten.

Und ich bin jetzt seit 4 Jahren Single..

Hier mal kleine Eigenschaften, die ich an einer Frau schätze:

Sie ist kreativ, spontan, ehrlich, Hoffnugsvoll, zu jeder Schandtat bereit, Emotionsreich, Freundlich, ironisch, Reisesüchtig, Neugierig, freiheitsliebend, humorvoll….

Zumindest bitte eins von den da oben…

und Sie liebt es neues zu Entdecken, und gibt sich ein klein wenig Mühe

Ich suche jemanden der mich auch mal pushed.

Über mich:

„Steh immer einmal mehr auf als du hingefallen bist“ trifft 100% auf mich zu.

Stelle mir 100 Fettnäpfe hin. Ich werde jeden Einzelnen mitnehmen, nur um am Ende sagen zu können: Es war nicht leicht, aber ich habe es geschaft.